+2
Fixed

Please help. Encountering "Error: Unable to check your review credit balance. Please try again"

sinkangtcm 1 year ago updated by Graeme 1 year ago 7

When I click on "Review Funnels", I keep encountering the message "Error: Unable to check your review credit balance. Please try again". 

I have tried refreshing but have not tried turning the plugin off and on. Can anyone please help?

Under review

Can you go to the Account page inside the plugin and make sure your license is activate and it doesn't say "Free" version?

Hi Josh, we encounter the same issue on all of our sites using the Plugin.

The license is activated and valid on all sites.

As it worked without any issues before it might be something infrastructure related with the origin Server where you retrieve the information from.

I haven't had time to check myself but I would suggest to check for an expired https certificate or something like this. That would be the only plausibel reason for only that part of the Plugin to suddenly stop working.

Hi,

I am having the same problem. I am unable to get reviews from Google and I get the following megssage. 


Error: Unable to check your review credit balance. Please try again.

Any help would be appreciated. 

Roddy

The plugin makes a call to the Freemius API and checks to make sure that the site domain is the actual site that is tied to the plugin and to keep track of the review credits. I'll need to log in to your site and see what's going on. Use the Contact Us link in the plugin then the "Technical Support" option, there is a spot to enter some login credentials so I can take a look.

+1

Hi there,

we were actually able to pinpoint the issue within the 11.4 branch of the plugin which was still used on our prod platform (11.4.4 to be precise). We have quite slow update cycles for stability and testing reasons. Our dev system was already on 11.5 and was running fine.

After updating both to 11.6.1 the review funnel functionality on prod works again as expected. And stayed functional on dev ;-).

So there seem to be some breaking changes within the freemius sdk updates you deployed between 11.4 and 11.5 and use for the funnel functionality.

If that's the core issue it should be easy to solve for the other posters as well by updating to 11.6.1 / the latest plugin version.

Best Regards,

Jan

Hi there Josh & Jan,


Appreciate the prompt response within the week.

I want to just wrap this up by sharing that I was just able to check the plugin version and indeed it was 11.5.0.

I just updated it to the latest version 11.6.1 and the review funnels tab now appears fine.

Image 1817


Image 1818


I want to thank you for the quick investigation and response to the matter.

Sincerely,

Frederick